Forgot your password?

BlackBerry Blend Working On Other Models

blend

As we have seen the launch of the BlackBerry Classic come and go, we have also seen updates to several apps.

Blend for Desktop and Mac as well as Blend handheld client all get updates as of yesterday. However aside from the updates we are seeing an interesting enablement for devices other than the Passport, Porsche Design and Classic. If you are by chance brave enough to be using a leaked release, you can now start using Blend, the hardware model blocking has been lifted.

Let us know what models you have this working with if you are using 10.3.x on a non-supported model. I will feedback later on other models myself, but I can vouch for the Z30.

14 total comments on this postSubmit your comment!
  1. is not working with Q10 + 10.3.1.1151 + latest version of Bled

  2. I have been using Blend with an iPad and also my laptop since yesterday connected to my Z30 that’s running 10.3.1.1154.

  3. Z10 works (STL 100-3)

  4. Using Z30 10.3.1.1151 and it’s working perfectly!

  5. Do you have to run 10.3.1.X or would 10.3.0.X work?

    • Amir. 10.3.0.x should technically work for devices that are not the Passport or Porsche Design. Both those were released with that version and Blend working as part of the launch. Just be sure to update both Desktop/Mac version and the Handheld version, it should then work for other devices if you are on 10.3.0.x. But still not guaranteed though.

BlackBerry© is a registered Trademark of BlackBerry Limited. BerryReview is in no way affiliated with BlackBerry Limited though sometimes their lawyers send us love letters...

Copyright © 2007-‘2016’ BerryReview LLC