Forgot your password?

Labyrinth v2.3.1 Adds Support for BlackBerry Torch 9810, 9850, & 9860

Labyrinth2 Labyrinth

Labyrinth 2 is one of my favorite BlackBerry games that I am missing on my BlackBerry Bold 9930. I just got a notification from our store that at Labyrinth has now added support for BlackBerry 7 devices, specifically the BlackBerry Torch 9810, 9850, & 9860 are now supported. Sadly the 9900 and 9930 are not since they do not have an accelerometer though hopefully the devs figure out a way around that maybe with the magnetometer.

Check out Labyrinth in the store or App World for $4.99. They also have a free Lite version in the store.

2 total comments on this postSubmit your comment!
  1. App World is driving me nuts, I purchased this app when I was using a 9800 and since I updated to a 9810 any app that is updated is not being reflected in my list of apps. This app continues to say it is not available for my device. “Refresh list” and alt RST do not help and when I look at the updated app it does not have the reinstall button but the purchase price button.

  2. You might want to check communicating with the developer. I did a week ago and I got my link after a day (I wrote on a weekend) :). Have fun!

3 total pingbacks on this post

BlackBerry© is a registered Trademark of BlackBerry Limited. BerryReview is in no way affiliated with BlackBerry Limited though sometimes their lawyers send us love letters...

Copyright © 2007-‘2016’ BerryReview LLC