Forgot your password?

Amazon BlackBerry App Now Available for OS 5.0

Amazon-bb I was driving a couple friends insane last week trying to get the awesome Amazon BlackBerry app on my BlackBerry Bold 9700. Amazon was blocking downloads from any OS 5.0 device for some reason and it was really hard to get a OTA download link because they create one time use download links.

Remzi let me know that Amazon has now opened up the download to OS 5.0 devices along with updating the application to version 1.0.25 from version 1.0.14 that I got before. Not sure what else is new but it downloads fine from my 9700.

Check it out at www.amazon.com/bb

Features:

  • Currently available for BlackBerry smartphones with a trackball or touch screen.
  • Buy millions of products wherever you go.
  • Access your existing Amazon account, cart, wish lists, payment and shipping settings, order history, 1-Click, and Prime benefits.
  • Snap a photo from your BlackBerry and we’ll search for a similar product available from Amazon.com.
  • All orders placed are processed by Amazon’s secure servers.
15 total comments on this postSubmit your comment!
  1. Not working on my Blackberry Bold 9700 with OS 5.0.0.296/5.1.0.83.

    The amazon.com/bb link is still trying to send my device the 1.0.14 version and tells me the app doesn’t work with my version of Blackberry OS

  2. Will not download on my BlackBerry 9700/5.0.0.296… Any idea?

  3. I downloaded 1.0.24 last week to my 5.0.0.328 Storm. And to my 4.7.1.61 Tour. I suspect I’ll holfd off trying to “upgrade” to .25 unless we see a change log that indicates something important was changed.

  4. Here’s a shortened URL directly to the download. http://tr.im/Gdad

  5. :we’re sorry, your device is currently not supported”, Nold 9000 with OS 5.0.0.238 :(

  6. My 8900 (OS 5.0.0.348) is also rejected (not supported yet). BOO!!!!

  7. This doesn’t seem to work with my Tour running 4.7.1.61. Anyone else having issues?

  8. I don’t use Amazon, So I just wanted to see what version they have for my Storm, Os 5.0.0.328.
    It shows 1.0.20v not 1.0.25v. I guess this update is just for the Bold 9700?.

    • They must have pulled .25. I am running .24 that I installed a week ago or so but when I check this morning from my Storm it offers my .20.

      From my BlackBerry Tour…

  9. Amazon BB refuses to download to my 8900 Curve (trackball available) with OS 5.0.0.348

  10. Still no go for my AT&T BB 9700. Only available for BB phones with a trackball or SurePress touch screen. Why would that make a difference…

  11. BB 8900 OS 5.0.0.411; still can’t download it which is frustrating since I was using it before with OS version 4.7… Guess I’ll just use Ebay since amazon charges sales tax anyways!!! >:-(

  12. BlackBerry Bold 9000 (AT&T) running 5.0.0.509.

    I cannot install the app because I get the “Device Not Supported error.

    I was using the heck out of this app on the most up to date official AT&T 9000 OS. 4.6.0.309 I tihnk it was.

BlackBerry© is a registered Trademark of BlackBerry Limited. BerryReview is in no way affiliated with BlackBerry Limited though sometimes their lawyers send us love letters...

Copyright © 2007-‘2016’ BerryReview LLC