Forgot your password?

Pandora 1.0.3 Released – Improves Wi-Fi Support & Speed

pandora1Slacker may be doing well but Pandora is still working hard to catch up. Nikolaus let me know that they have released version 1.0.3 of Pandora for BlackBerry which is an upgrade from the previous 1.0.2. Previous versions worked with Wi-Fi but it was not officially supported and was slow on many Wi-Fi devices. It looks like now it is officially supported since the logo is included in the app between the battery and reception indicators.

The only other noticeable difference is that the version number is now shown at the top of the application. Let me know if you notice anything else changed!

You can pick it up OTA by just heading to from your Berry’s browser or go to from your desktop. If that does not get you the new version try directly OTA at this link.

8 total comments on this postSubmit your comment!
  1. Here is a summary of some of the changes in this build:

    – Support for Wi-Fi on devices that have it (using a high quality AAC-HE stereo audio stream)
    – Bluetooth support (you can now explicitly enable it and disable it rather than relying on the default audio routing in the device)
    – Options screen (accessible from Station List menu) to select preferences for Bluetooth and Wi-Fi (on wi-fi capable devices)
    – Support for the Nextel 8350i (only over Wi-Fi)
    – Keyboard shortcuts, including pause/play functionality using the mute key (even when Pandora is running in the background)
    – Focus cursor on Now Playing screen should be easier to control on trackball devices
    – Various other minor enhancements and fixes

    • @Marc: I tried Pandora on on my 8900 because others said it worked, but I got a DNS Licencing error. I went back to and even though Pandora always worked under 4.6.1 for me, now I get the same error, even thought how it says an “unknown licencing error”. Can you shed any light on for me for this error and how I can fix it? Thanks!!!

  2. Not working on OS, unfortunately. Installed, rebooted, and ran app = “Error starting pandora $2dradio: Module ‘pandora $2dradio-1’ attempts to access a secure API.” This is weird considering 1.02 worked just fine on OS 5. Hopefully they will address this incompatibility soon!

  3. No caching? Meh. Wake me up when they add caching like slacker.

  4. i will NEVER understand why caching is such a big deal! freaking get in an area where you have decent service or get a new carrier already.

1 pingback on this post

BlackBerry© is a registered Trademark of BlackBerry Limited. BerryReview is in no way affiliated with BlackBerry Limited though sometimes their lawyers send us love letters...

Copyright © 2007-‘2016’ BerryReview LLC